Minimal required version of Flash player is 9. Please, DOWNLOAD IT NOW Nedryland, NEDRYLAND,The Project Nedryland, Jurassic Park Online System - Project nedryland